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The Timesheet detail view 
 

The timesheet detail view allows users to review and enter work hour entries.  

The view is split into four panes. 

 

Summary Pane  
 

The upper left pane showing total hours registered for the crew member for 
the selected date range. 
 

Conformance pane  
 

The upper right pane showing descriptions of any breaches of regulations for 
selected days 
 

Timesheet pane  
 

The middle pane showing the list of timesheet entries 
 

Paint Pane  The Lower pane showing a graphical representation of time based entries 
 

  



How to find the timesheet detail view 
The timesheet function can be accessed from two different places in the TM Master V2 program 

(depending on user rights) 

1. In the crew module 

    

1. Select [Crew] → [Crew List] on the main side menu 

2. Double click a crew member 

3. Select the “Timesheet” tab 

 

 

 

 

 

 

 

 

2. In the My Place module 

 

1. Select My Place → My Crew 

2. Select the ”Timesheet” tab (if more than one tab is available) 

  



How to add work entries in the timesheet pane 

 

1. Click the [Edit Time sheet] button on the toolbar of the time sheet pane 

2. Click in the first empty line of the grid 

3. Set the date 

4. Set the ‘Work hour Category’ 

5. Enter the times or count accordingly 

6. Either 

a. Click on the next empty line to add another entry and save the one you’ve just entered. 

Or 

b. Click the ‘Edit Time Sheet’ button again to save the entry. 

 

Tip #1: While editing the time sheet grid, pressing the [Enter] key will move the currently active cell one 

place to the right. 

Tip #2:  When entering times in the ‘From’ and To’ columns, it is not necessary to type the semi-colon.  

For example, 12 o’clock can be typed simply as ‘12’ or ‘1200’, both will be accepted. 

Note: For point 5 of this procedure, which column(s) you need to fill in depend on which ‘Work Hour 

Category’ is chosen.  If a time based work hour category is chosen then, the times ‘From’ and ‘To’ 

columns need to filled in.  If a count work hour category is chosen then the count column should be 

filled in.  If a daily type work hour category is chosen then none of the columns need to filled in.  Work 

hour categories are described in more detail in the ‘Work Hour categories section later in this manual. 

  



How to add work entries in the paint pane. 

1. Click the  paint button on the toolbar of the paint pane 

2. Select which “Work Hour Category” you wish to use from the drop down 

3. Click and drag in the paint grid to ‘paint’ the hours. 

4. Click the Paint button again to save the changes 

 

Note #1: Only time based work hour categories are available from the drop down in the paint pane. 

Note #2: Time based entries entered within the paint pane will be automatically added to the timesheet 

pane and vice versa. 

 

How to turn the Timesheet pane and the paint pane on and off. 
1. Navigate to the timesheet detail view 

2. On the uppermost toolbar, either  

a. Click this button  to turn the timesheet pane on/off 

b. Click this button  to turn the paint pane on/off 

 

How to change the shown date range for timesheet. 
1. Navigate to the timesheet detail view 

2. On the uppermost toolbar, set the date interval using the drop down box 

3. Use the two arrow buttons to move the date range backwards and forwards as desired.

 
 

 

 

 

 

 

 



How to calculate conformance 
1. Navigate to the timesheet detail view 

2. Set the date range as desired 

3. Click this button  to check conformance for the chosen date range 

 

How conformance is shown 
After clicking the ‘Recalculate Conformance’ button, a number of columns within the timesheet pane 

will be populated with Work Hour and Rest hour figures.  In addition, to the left of each entry (both in 

the timesheet pane and the paint pane), a coloured ball will be shown to represent the different levels 

of conformance.  These coloured balls can be one of five different levels. 

 Red – A non-conformance (one or more of the regulations has been broken)  

 Yellow – An exception has been utilized  

 Green/Yellow – This entry is a contributing part of an exception period  

 Green – This entry is in accordance with all regulations  

 Grey – Recalculation of Conformance is required click [Recalculate] button 
 

 

In cases where the ball is anything other than green or gray, there will also be text shown in the 

‘Conformance’ pane detailing which regulations have been broken or which exceptions have been 

utilized. 

 

How to add work periods for several days at once 
To save time recording the hours, if the work schedule is similar over a period of time, the  

[Add multiple workhours per day] can be used 

1. Navigate to the timesheet detail view 

2. Click the [Add multiple workhours per day] button   on the uppermost toolbar 

3. In the new window, select the ‘Work Category’ 

4. Set the dates ‘From’ and ‘To’ 

5. Depending on work category chosen, either 

a. Paint the hours you wish to add 

Or 

b. Enter the count number to be added 

6. Click ‘Add Work Hours’ 



 

Note: Depending on the number of days selected, it may take some time to add all the entries.  A 

progress bar will keep you updated. 

 

How to generate the hours of rest report 

 

1. Navigate to the timesheet detail view 

2. Click the [Report] button   on the uppermost toolbar 

3. In the new window, select the month and year 

 



 
 

4. Select the crew type (please see the note under) 

5. Select the Regulation 

6. Select the Authorised Signer (optional) 

7. Select the Competent authority (optional) 

8. Click OK 

9. The two page report will now be generated, click print to obtain a hard copy. 

10. To save the report as a PDF, click File → Export, Click OK and then select a location to save the 

file to. 

Note: The crew type can be either the default crew type for the crew member, or the crew type that 

they are signed on as. 

 

How to view the change history for the timesheet 
1. Navigate to the timesheet detail view 

2. Set the date range as desired 

3. Click this button  

4. All change history will be shown for the chosen date range 

 

Note:  Change history consists of all changes made to entries after they are confirmed.  This includes 

when each entry is set as approved and processed, as well as cancellation of these statuses.  This does 

not, however, include when confirmed is cancelled.  In this particular case, the history for those entries 

that have confirmed cancelled, the history record is reset. 



 

How to confirm work period entries 
1. Navigate to the timesheet detail view 

2. Select one or several lines in the timesheet pane grid 

3. Click the [Confirm entries] button  on the toolbar 

4. You will then be asked to confirm various situations dependent on the data. 

Note: This will confirm all entries on the same date and all previous dates (please see ‘Consistency in 

confirmation’ below), lock the date for editing (adding or changing entries) and perform a conformance 

recalculation. 

 

How to cancel confirmation of work period entries 
1. Navigate to the timesheet detail view 

2. Select one or several lines in the timesheet pane grid 

3. Click the [Remove confirmation] button   on the toolbar 

4. You will then be asked to confirm various situations dependent on the data. 

Note: This will cancel the confirmation of all entries on the same date and all subsequent dates (please 

see ‘Consistency in confirmation’ below).  It will also unlock the days for editing and delete any saved 

non-conformances for those days. 

 

Consistency of confirmation: 
It is not allowed to create a gap in the confirmation.  By this, we mean that you are not allowed to 

confirm a day and have days before it which are not confirmed.  The same logic is also used for Approval 

and setting entries as Processed.  When confirming an entry, you will be informed of which days you are 

confirming and which (if any) non-conformities will be saved as a result of confirming the entries.  

(Please refer to the section about ‘Conforming, Approving and processing’, later in this manual for 

further details).  This consistency is also necessary when cancelling confirmation, all days after the 

chosen date will also have their confirmation cancelled.  Consistency is necessary due to the nature of 

Hours of rest calculation and the need to record non-conformances. 

  



 

The TimeSheet overview 
The timesheet overview allows you to review the total number of timesheet entries of different types 

for a given date range, as well as the total number of non-conformances and exceptions based on the 

regulations in force (upper pane). 

Approval of timesheet entries and setting them to processed is carried out from this view (lower left 

pane). 

Any Non-conformances are also described in the lower right pane when the appropriate dates are 

selected in the lower left pane. The timesheet overview can be accessed both from the main Fleet side 

menu (office only) and the Crew module main menu. 

 

  



How to review timesheet data in the Timesheet overview. 

 

1. Navigate to the timesheet overview 

2. Set the From and To dates 

3. Click Refresh 

 

Tip:  All the data displayed in the time sheet overview grid can be copied out to an excel sheet.  Select 

the data you wish to copy, right click and select ‘Copy content to Clipboard’.  You can then paste the 

data directly into an empty excel sheet. 

How to Approve work period entries 
1. Navigate to the timesheet overview 

2. Set the From and To dates for the desired date range 

3. Click Refresh 

4. Select the crew member(s) you wish to approve entries for in the upper pane 

5. Select the entries in the lower grid that you wish to approve 

6. Click the [Approve selected entries]  button on the lower left toolbar 

7. Confirm the approval in the new window 

Note: Only entries which have been ‘Confirmed’ can be approved.  Attempting to approve unconfirmed 

entries will not affect them.  Approving an entry will automatically approve all other entries for that day 

and all those on previous days to maintain consistency.  (Please refer to the section about ‘Conforming, 

Approving and processing’, later in this manual for further details) 

How to Set work period entries as processed 
1. Navigate to the timesheet overview 

2. Set the From and To dates for the desired date range 

3. Click Refresh 

4. Select the crew member(s) you wish to process entries for in the upper pane 

5. Select the entries in the lower grid that you wish to set as processed 

6. Click the [Set to Processed] button on the lower left toolbar 

7. Confirm the approval in the new window 

Note: Only entries which have been ‘Approved’ can be set as ‘Processed’.  Attempting to process 

unapproved entries will not affect them.  Processing an entry will automatically process all other entries 

for that day and all those on previous days to maintain consistency.  (Please refer to the section about 

‘Conforming, Approving and processing’, later in this manual for further details). 

 



How to set up Timesheet for the fleet 
Before Time sheet can be used by all users to maintain their work hours and hours of rest records, a 

number of steps have to be carried out at the office installation to prepare the system for use. 

1. Import a Time Sheet regulation set 

2. Set the default regulation set date range 

3. Set the regulation set date range for individual units 

4. Populate the ‘Work Hour Category’ code table 

Each of these is handled in detail below.  Regulation sets are provided by Tero Marine as an xml file 

containing the regulations for hours of work/rest which are applicable for your vessels.  These 

requirements can vary according to flag state and trading area, but most companies conform to one or 

many international rule sets recommended by IMO.  Please contact Tero Marine for more information. 

 

How to Import Time Sheet regulations 
 

1. Go to [System] → [Settings] and select the “Time Sheet Regulations” tab 

2. Click this [Add Regulation]  button on the toolbar 

3. In the new window, click this button [Import XML] on the toolbar 

4. Navigate to the file you have received from Tero Marine and select it 

5. The file will now import and the regulation structure will show in the window 

6. Click Save and close 

 

How to Set the default regulation set date range 
1. Go to [System] → [Settings] and select the ‘Time Sheet Regulations’ tab 

2. Double click on the regulation set in the grid 

               

3. Select the ‘Units’ tab 



4. Click the [Add to Unit]  button  on the toolbar 

               

5. In the new window, select ‘Fleet wide’ in the unit drop down 

6. Set the ‘From’ date to today or before 

7. Click save and close 

Note: it is not necessary to set the ‘to’ date, as this is effectively the default regulation set for all 

instances where dates are not covered by other regulations. 

 

How to Set the regulation set date range for specific units 
1. Go to System → Settings and select the ‘Time Sheet Regulations’ tab 

2. Double click on the regulation set in the grid 

3. Select the ‘Units’ tab 

4. Click the [Add to unit]  button  on the toolbar 

               

5. In the new window, select the desired unit in the unit drop down 



6. Set the ‘From’ date to the desired start date for that particular unit 

7. Set the ‘To’ date to the desired finish date for that particular unit. 

8. Click save and close 

Note: if all the vessels in the fleet are to always use the same regulation set, then it is only necessary to 

set the default regulation set (you are not required to specify date ranges for each unit) 

 

Information about Work Hour Categories 

 

Work Hour categories are initially entered in the Administration → Codes module (please refer to the 

general manual for how to administrate codes).  Each work hour category can be set as one of three 

different ‘Registration Types’ 

 

Time Period – typically used for normal work hour registration categories requiring a time from and to 

Count – typically used to add bonus hours where those hours are not to be registered as ‘time worked’ 

Daily – typically used to categorise whole days. 

Examples of these could be; 

- Time Period – Normal Work, Overtime, Drill, Mooring etc. 

- Count – Rope Handling Bonus, Bonus Hours 

- Daily – Offshore days, Office Days, Off Pay Days, War Zone Days 



Information about the time sheet user rights 
There are a number of user rights to control the access and functions within the timesheet module.  

Some of these need to be used in conjunction with the user rights for the Crew module to gain full or 

partial access to crew records and their time sheets.  Below is a list of the current user rights which are 

exclusively for the timesheet function (these may be added to in later versions) 

 

 

Read → Can View the Timesheet records in the crew 
module (not necessary if the user has the Crew → 
Read user right) 

Edit → Can Edit Timesheets for his/her own crew record 

Add → N/A 

Delete → N/A 

EditGrid → N/A 

EditOthers → Can Edit Timesheets for all crew records 

ConfirmOwn → Can confirm own time sheet records 

ConfirmOthers → Can confirm time sheets for other crew members. 
Note, this will not allow confirming of own 
records unless user can confirm own 

CancelConfirmed → Can cancel confirmation of timesheet records 

ApproveOwn → Can approve own timesheet records 

ApproveOthers → Can approve time sheets for other crew 
members. Note, this will not allow approving of 
own records unless user can approve own 

CancelApproved → Can cancel approval of time sheet records 

ProcessOwn → Can set own time sheet records as processed 

ProcessOthers → Can set time sheet records as processed for other 
crew.  Note, this will not allow the user to set 
their own records as processed unless they have 
Process own. 

CancelProcessed → Can Cancel processed for time sheet records 

Admin → Can administrate time sheet regulations 

BonusAdministration → User can add approved Count and Daily type time 
sheet entries for any dates for any user.  This is 
intended for the administration of additions and 
bonuses to actual working hours. 

 

  



Confirming, Approving and Processing 
The timesheet function has been implemented with a 3 level approval system (Confirm → Approve → 

Process).  The ability to set the levels and, if necessary, cancel them is totally controlled by the Usr rights 

detailed above.  It is therefore possible to distribute responsibility for setting the approvals as you see 

fit.  Here is a brief description of the levels 

 

[Confirm]  

 This is normally done one crew member at a time from the time sheet detail view.  However, it can be 

done from the timesheet overview as well (this has been added to make it easier for users that are 

responsible for confirming entries for other crew) 

When a user confirms a timesheet record a number of different operations are set in motion.   

The first is a consistency check, which will check if there are any unconfirmed entries on days before the 

selected one.  If there are, then the user is informed that these will also be confirmed (as well as any 

other time sheet records for the same day).   

The second operation is that the day will locked for editing.  This will also stop any new records being 

added for the selected date (or previous dates).  There is one exception to this rule and that is if a user 

has the ‘BonusAdministration’ user right.  This enables a user to add ‘Count’ and ‘Daily’ time sheet 

entries for ‘locked’ days.  The thought behind this is if bonuses and additions are administrated from the 

office, after time sheet hours have been confirmed and approved. 

The third operation is that a ‘Hours of Rest’ conformance recalculation is performed.  Any non-

conformances that are found will be displayed to the user for additional confirmation.  If confirmed 

these will be saved as part of the Non-Conformance history for that crew member.  This history is then 

utilized in the time sheet overview to generate the total number of Non-conformances and exceptions 

for each crew member for specified date ranges. 

Confirming is intended for each individual crew member to confirm that they are finished with data 

entry for those days that they have confirmed.  However, as it is user right controlled, it is possible to 

designate any user to confirm someone’s time sheet entries. 

Who confirms the time sheet record and when they have confirmed it, is logged within the system. 

 

[Approve]   

This can only be done from the timesheet overview.  

A consistency check is also performed for approval so, if there are records before the selected one that 

have not yet been approved, they will also be approved.  It is only possible to approve confirmed 

timesheet records.  Any attempt to approve unconfirmed records will not affect those records. 

Approval is just a stamp or flag for a timesheet entry.  Which user has approved the entry and when 

they approved are logged within the system. 



Approval is intended for senior officers to approve crew member’s timesheet entries as genuine.   

However, as it is user right controlled, it is possible to designate any user to approve someone’s time 

sheet entries. 

 

[Processed]  

 This can only be done from the timesheet overview.  

A consistency check is also performed for processed so, if there are records before the selected one that 

have not yet been processed, they will also be set as processed.  It is only possible to set records as 

processed if they are approved.  Any attempt to process unapproved records will not affect those 

records. 

Processed is just a stamp or flag for a timesheet entry.  Which user has processed the entry and when 

they set it as processed are logged within the system.   

Processed is intended for office administration staff to set crew member’s timesheet entries as 

processed to indicate that they are either witnessed or transferred over to an external system (payroll 

for example).   However, as it is user right controlled, it is possible to designate any user to process 

someone’s time sheet entries. 

Note: From the date that a timesheet record has been set as processed, there is a 30 day window to 

cancel the status ‘Processed’ before the timesheet record is permanently locked. 

 

Cancelling timesheet record approval levels.       

Each approval level can be cancelled provided that the user has the appropriate user right to do so.  The 

exception to this is processed if the record was set as processed more than 30 days ago. 

Cancelling must take place in the reverse order, so for example – it is not possible to cancel approve for 

records that are set as processed. 

There is also a consistency check involved in the cancellation of all approval levels.  This means that 

cancellation of an approval level (confirmed, approved or processed) will result in the automatic 

cancellation of the same approval level for all records after the selected one. 

For the cancelling of processed and approve, this simply involves the date and time of these levels being 

removed as well as change log record being created for the cancellation. However, for cancelling the 

confirmed level, a number of other operations are performed.  For this situation, the change log history 

for those records is also removed, as well as any ‘Hours of Rest’ Non-conformance history that has been 

saved for those records. 

 

 


